Outage: Worldpay Card Processing Unavailable Due to Cloudflare Outage

Incident Report for PaymentExpress

Postmortem

Incident Summary

On Friday, December 5, 2025, PaymentExpress experienced a service degradation where all card payment processing was unavailable between 3:47 AM ET and 4:11 AM ET.

The root cause was a dependency failure at our primary card processor, Worldpay, which was itself impacted by a global outage at Cloudflare. Our PaymentExpress platform remained stable throughout this period, and other tender types, such as e-checks and PayPal, continued to operate normally. 

Although the failure was upstream, we take any disruption to our core services seriously. We apologize for the interruption in card processing and are taking proactive steps to shield our platform from external infrastructure failures in the future.

Root Cause Analysis

The incident was directly caused by the temporary unavailability of Worldpay, our third-party card processing partner, which was disrupted by a global service outage at Cloudflare.

The PaymentExpress application remained fully available, but since it could not establish a connection to Worldpay for authorization or settlement, all card-based payments failed during the 24-minute window.

Cloudflare has published a detailed, technical analysis of their outage: Cloudflare Post-Mortem Link

Impact

The primary impact was the inability to process payments using credit or debit cards for 24 minutes. All other payment methods (e-checks, PayPal, etc.) were unaffected and processed successfully throughout the incident.

Resolution

Service was restored automatically at 4:11 AM ET when the connectivity issues affecting the underlying Worldpay infrastructure were resolved. No intervention was required on the PaymentExpress platform to restore card processing.

Action Items

Our reliance on the public internet to communicate with essential third-parties (such as Worldpay) creates dependencies (like Cloudflare) which can be mitigated by establishing direct links between our infrastructure and theirs. We are exploring the feasibility of direct links with Worldpay, and plan to implement the solution if viable.

Posted Dec 05, 2025 - 22:17 UTC

Resolved

The issue that caused card processing to be unavailable has been resolved.
Posted Dec 05, 2025 - 09:11 UTC

Investigating

We are currently investigating this issue.
Posted Dec 05, 2025 - 08:47 UTC
This incident affected: Payment Processors and Gateways.